icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.toryburchoutletcheap.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

北京28 www.80pz.cc-天干地支与彩票| www.142933.com-8彩app安全吗| 大赢家彩票平台www.703602.com| www.1zn.com-彩装膜批发市场| www.732560.com-彩乐汇平台-| www.nc25.com-乐米彩票改版| www.188533.com-快三平台代理提成| www.171.com-时时彩ios版下载| www.097654.com-手机彩票真假| www.756058.com-旺彩超级大乐透下载| www.12gf.com-2013体彩排列三| www.5544.cn-幸福彩大乐透推荐号| www.365380.cc-七彩大乐透彩票| www.526880.com-中国福利彩票十乐彩| www.668683.com-福利彩票彩票走势图| www.798595.com-078彩票平台| www.907276.com-怎么玩彩票稳赢| www.987237.com-福利彩票站点查询| www.lq2.com-快三游戏网络平台| www.tj56.com-亚洲彩票官方网| www.856023.com-足彩返水是什么意思| www.793285.com-彩票中奖后人身安全| www.806680.com-彩票亏损救援金| www.130800.com-彩票计划公式赚钱骗| www.166285.com-内蒙古快三走势图| www.303418.com-优乐彩登录-| www.422741.com-彩票投注金额计算器| www.559032.com-棒棒彩票下载app| www.693856.com-彩77彩票怎么样| www.855568.com-七乐彩守号最长的| www.8289.cm-今天福彩3d推选号| www.274586.com-快三驾吗-| www.323795.com-乐彩国际-| www.996116.com-足彩19037推荐| www.rg22.cc-红牛快三平台| www.273546.com-彩票作假-| www.367886.com-刚力彩芽男朋友| www.092659.com-福建福利彩票中心| www.qv26.com-彩票pc是什么意思| www.397422.com-七星彩春节休市| www.669918.com-云彩票app-| www.811588.com-优博彩票平台官网| www.11687.cc-福利彩票开奖3d| www.83uv.com-乐橙彩票-| www.386815.com-盛彩彩票假的吧| www.531582.com-彩特吧高手网| www.50fj.com-烟台福彩中奖号码| www.40ue.com-彩礼相关法律法规| www.13431.com-足彩计算方法| www.949231.com-福利彩票3d之家| www.ao87.com-q彩-| www.39376.com-彩票挂机方案技巧| www.70442.com-顶尖彩票如何提现| www.562103.com-私彩2015-| www.058759.com-3d胆码预测家彩网| www.89237.com-爱情幸运号彩票| www.51tt.cc-创意水彩笔画图片| www.09yx.com-福彩封机时间| www.88wp.com-985彩票网-| www.67ih.com-山西时时彩开奖结果| www.620506.com-500彩票怎么玩| www.859971.com-360度快三计算器| www.748128.com-快三和值大小单双| www.870846.com-福彩3d幸运码软件| www.942284.com-投注彩票兼职是真的| www.996643.com-黑龙江福彩领奖地址| www.cw99.cc-网易彩票平台可靠吗| www.185723.com-甘肃福彩快三开奖号| www.66xh.cc-优游时时彩-| www.521811.com-新浪爱彩必发指数| www.858930.com-上期彩票中奖号| www.925820.com-彩富网快码-| www.975473.com-蚂蚁彩票可靠吗| www.4527.cn-七星彩册子信息| www.9726.vip-彩票站转让协议| www.138424.com-中港彩票赛车| www.77427.com-体育彩票店赚钱吗| www.14104.com-每日体彩31选7| www.790988.com-广州彩烟-| www.938184.com-双赢彩票可靠吗| www.991589.com-彩票vip下载| www.rf74.com-彩6彩票平台| www.983140.com-新盈彩怎么玩| www.mp.com-网络彩票快三| www.ya63.com-河北快三推荐和值| www.77127.cc-体育彩票分析网站| www.395393.com-预测港彩生肖及方法| www.548261.com-彩票快三投注技巧| www.615208.com-微信玩彩票群| www.720064.com-彩乐汇是真的假的| www.978486.com-天天好彩生肖号码| www.678712.com-注册保证能领到彩金| www.809860.com-解读新彩票管理条例| www.900006.com-重庆时时彩爱彩乐| www.974894.com-彩票投注站电话号码| www.88ij.com-帮别人买彩票赚佣金| www.5629.wang-网上买彩票被骗过程| www.962191.com-彩涂铝卷加工| www.821012.com-3d彩圣-| www.938029.com-福彩好运2玩法| 盈宝彩票www.ybao3.com| www.872379.com-福彩助手app| www.963584.com-3分彩开奖结果| 盈彩www.890752.com| www.63wl.com-彩票软件哪家好平台| www.865931.com-彩票123是真的吗| www.948162.com-江西体彩官方网站| 凤凰彩票www.77801k.com| www.fr27.com-福彩快3输了一百万| www.761236.com-东莞体育彩票网站| www.028012.com-网上买彩票亏了| www.5gy.cc-常州体彩中心案件| www.77qr.com-彩票30块钱-| www.8617.cn-久盈时时彩-| www.35892.com-福彩搞笑宣传语| www.610094.com-做梦梦到买彩票中奖| www.7391.live-色彩构成马赛克图片| www.ln45.com-彩中彩平台怎么样| www.0888.pw-火星彩票网-| www.687032.com-中彩天下彩449| www.67fq.com-红利彩票登录网站| www.503175.com-学生可以买彩票吗| www.043178.com-彩票的广告语| www.220423.com-彩票破解器软件| www.802412.com-玩彩票输钱能报警么| www.892397.com-赌快乐彩好方法| www.956990.com-彩盈登录注册| www.997042.com-d8彩票分分快三| www.fy95.com-英国时时彩开奖| www.223249.com-凤凰彩票专属计划群| www.424230.com-福利彩票内部人员| www.576486.com-唐山福彩中心| www.679140.com-安装下载彩经网| www.880692.com-5分快三是官方彩吗| www.36lf.com-七星彩中间值走势图| www.5542.vip-香港万彩吧彩票| www.635715.com-博彩e族中国彩票| www.96127.com-中国福利彩票7月| 大赢家彩票www.5086p.com| www.237439.com-中竞彩网首页| www.16786.com-福彩3d购彩公式| www.211131.com-安徽省快三遗漏号码| www.95sf.com-快彩真的能赚钱吗| www.37no.com-ios大公鸡七星彩| www.169097.com-快三胆拖表-| www.35jh.com-最新局王七星彩奖图| www.884833.com-至尊争霸彩票安全吗| www.738852.com-福彩3d微信公众号| www.791721.com-领奖彩票app| www.863487.com-体育彩票排列五秘诀| www.916129.com-买私彩报警有用吗| www.967904.com-福彩14名领导死刑| 中国福利彩票www.08588s.com| www.wa48.com-福彩快三讨论交流群| www.148503.com-天天彩票优惠大厅| www.040059.com-福彩推荐号今日快三| www.403839.com-福彩双色球骗局| www.524356.com-香港首创彩经一码| www.093310.com-全部彩种免费计划表| www.076601.com-老梁揭秘彩票那些事| www.511035.com-六色彩虹缺哪个颜色| www.7393.pw-中国体育竞彩店转让| www.76159.com-足彩倍投计划app| www.044785.com-牛彩一湖北快三专用|